Child tag bug when using another tag

Anything shuushuu related that doesn't fit into the other forums :)
Post Reply
User avatar
Merun
Posts: 2897
Joined: Sat Mar 17, 2007 9:44 am
Location: NoWheRe

Child tag bug when using another tag

Post by Merun » Mon Jan 26, 2009 2:20 pm

I can't really find the pattern, but right now, when I search for both "mizugi" and "Mitha", shuushuu only return one image.

http://e-shuushuu.net/search/results/?tags=4+1765

There should be more since there are also other image tagged with "two piece" which is a child tag. If I use "mizugi" alone, I will get also "two piece" tagged images.



On the other hand, I don't have this problem if I try "wings" and "Mako Tatekawa" for instance, image tagged as "tenshi" do appear. Right now I only have "mizugi" with this problem.
Merun @ Twitter

User avatar
A.Dantes
Posts: 172
Joined: Wed Nov 14, 2007 11:13 pm

Re: Child tag bug when using another tag

Post by A.Dantes » Mon Jan 26, 2009 3:36 pm

A little bit of testing shows that this is specifically an issue with the Two Piece tag. Search for Mizugi and remove Mizugi from all the images that only feature Two Pieces (where it shouldn't have been in the first place), and they disappear from the search results. School Mizugi is having the results expected, however.

I'll try to look into this further this evening.

Edit:
Or now. You'll find similar issues on live with any tag that has multiple children.

Issue found, identified, and corrected on testing.

Post Reply