Does my avatar not work?

Anything shuushuu related that doesn't fit into the other forums :)
Post Reply
User avatar
primetch
Posts: 45
Joined: Thu Nov 08, 2007 1:35 pm
Contact:

Does my avatar not work?

Post by primetch »

As I've mentioned before, my imageboard is a nasty little beta system, so I'm never sure if it's working or not. Do you see my avatar, or is there a little red X there instead?
[witty remark here]
User avatar
Ran
Posts: 2655
Joined: Thu May 04, 2006 11:57 am
Location: Canton, Ga
Contact:

Post by Ran »

Image
Image
User avatar
A.Dantes
Posts: 172
Joined: Wed Nov 14, 2007 11:13 pm

Post by A.Dantes »

Your webserver is set to disable hotlinking of images. If any request for the image is made where the referer field is not blank or set to your website, the server responds with a 403 Forbidden message.
User avatar
Ran
Posts: 2655
Joined: Thu May 04, 2006 11:57 am
Location: Canton, Ga
Contact:

Post by Ran »

Just save it to your comp, upload it, then delete it from your system.
Image
User avatar
primetch
Posts: 45
Joined: Thu Nov 08, 2007 1:35 pm
Contact:

Post by primetch »

Is it possible to enable hotlinking (a property?) or is it just hopeless to do so on a free webspace account?

(I like the pictorial advice too.)
[witty remark here]
User avatar
A.Dantes
Posts: 172
Joined: Wed Nov 14, 2007 11:13 pm

Post by A.Dantes »

On an Apache web server, the only two places I know of to place directives which would result in this behaviour would be in an .htaccess file inside that folder or one of its parents or inside Apache's httpd.conf. I have a feeling the answer will be the latter and that will be out of your control.

It may be possible to override this behaviour. Try placing a file named ".htaccess" in the same folder as your images with the following contents:

Code: Select all

RewriteEngine On
RewriteRule (.*) - [L]
I really wouldn't recommend attempting to enable the ability to hotlink images, though.
User avatar
primetch
Posts: 45
Joined: Thu Nov 08, 2007 1:35 pm
Contact:

Post by primetch »

I've taken the .htaccess advice and have yet to see improvement. I'm also contacting the people that run the UK hosting site; maybe they're blocking it. Augh.
[witty remark here]
Post Reply